This project has moved and is read-only. For the latest updates, please go here.

Error when trying to use Filter List

Jul 12, 2012 at 5:26 PM

I am getting the following error when trying to use the Filter list option in ver. 0.7.1 and 0.7.4.  This is a new install on an Win XP with Office 2007.

The server threw an exception. (Exception from HRESULT: 0x80010105 (RPC_E_SERVERFAULT))

  at System.RuntimeType.ForwardCallToInvokeMember(String memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)

  at Microsoft.Office.Interop.Excel.PivotChache.get_ADOConnection()

  at OlapPivotTableExtensions.MainForm.ConnectAdomdClientCube()

  at OlapPivotTableExtensions.MainForm.workerFilterList_DoWork(Object sender, DoWorkEventArgs e)

Jul 12, 2012 at 5:49 PM

Hmm. Looks like it's a connection error of some sort. Is there anything funny about the connection or the authentication you use on the connection? Are you signed into your laptop under the same credentials you're using to connect to the cube? Can you successfully refresh the PivotTable itself? Does it succeed if you shut down all Excel windows, then restart Excel, open your document, refresh the PivotTable, and use Filter List immediately?

Can you open the Data tab and click the Connections button and click Properties on the connection in question and copy and paste the connection string here (obviously masking the server name and such).

Any info you can provide that would help me reproduce the problem would be helpful.

Jul 13, 2012 at 5:46 PM

This is happening every time I try to use the software.  Closing Excel and opening does not resolve the issues and neither has rebooting the system.  I am able to refresh the pivot table and bring in data that I want to filter on.  It is happening when I just click on the OLAP PivotTable Extension program from my Right click.

Below is the string that the Ad Hoc is using.  I have installed this on a number of other machines in my company and never have had this issue before.

Provider=MSOLAP.4;Integrated Security=SSPI;Persist Security Info=True;Initial Catalog=Company Name;Data Source=sqlreport;MDX Compatibility=1;Safety Options=2;MDX Missing Member Mode=Error

I would send screen shots if was able to upload them.


Jul 13, 2012 at 6:55 PM

That connection string doesn't look unusual.

I'm at a loss and I can't reproduce this issue. If you have any suggestions to try, please let me know. I'm sorry it's not working!

Aug 1, 2012 at 5:47 PM


I have removed the software from the users system and tried installing the 0.7.4 ver again and I am getting the following errors when trying to launch the program.


ERROR FIGURING OUT WHETHER IT'S AN INVALID CONFIGURATION! Attempted to read or write protected memory. This is often an indication that other memory is corrupt - System.AccessViolationException

at System.RuntimeType.ForwardCallToInvokeMember(String memberName, BindingFlags flags, Object target, Int32[] aWrapperTypes, MessageData& msgData)

at Microsoft.Office.Interop.Excel.PivotCache.get_WorkbookConnection ()

at OlapPivotTableExtensions.MainForm.get_IsSupportedLanguageConfiguration ()


Does this help with what would then be causing my other issues as I get the original error then when trying to filter.

Aug 1, 2012 at 6:36 PM

That's very odd. Try the following. If you click on the PivotTable then press Alt-F11 then Ctrl-G then paste the following into the Immediate window and press enter:


It should return the name of the connection. Does it do that or does it return an error? We're essentially testing with VBA the same bit of code my add-in is using.

The other possibility is that there's something odd about the language setup of this install. Can you go to the About tab of my add-in and describe what it says about the languages and the version of the PivotTable?

Marked as answer by furmangg on 6/9/2014 at 12:56 AM
Aug 1, 2012 at 9:04 PM

I pasted the string into the VBA window and it returned a Macro box with nothing in it.  When I tried to launch the program again it gave the same error and on the About tab it is saying I am using an Unsuppported Language Configuration. The tab looks like this:


OLAP PivotTable Extensions v0.7.4.0 (32-bit)

Windows Language: English (United States)

Windows UI Language: English (United States)

Excel UI Language: English (United States)

Excel Install Language: English (United States)

Unsuppported Language Configuration

Version of This PivotTable: 2007

Aug 1, 2012 at 9:26 PM

It definitely troubles me that Excel can't figure out the workbook connection for the PivotTable. Does this happen on every PivotTable, even one you build from scratch?

If you go to the Data tab and click Connections, highlight the connection in question, and click the "Click here to see where the selected connections are used" link at the bottom, does it tell you that your PivotTable is actually using that connection?

I'm not sure what else to suggest. There's something unusual with your installation or PivotTable or something. If you'd like to click the furmangg link and contact me, we can exchange emails and you can email me the workbook in question if you'd like me to look at it and try it on my laptop.