This project has moved and is read-only. For the latest updates, please go here.

Error when filtrering

Nov 14, 2012 at 12:22 PM


In a production environment i installede 32bit version on my machine and as a developer I am a local administrator and also cube administrator and I could use add-in and filtrering with no problems.

However, when making servicedesk install add-in on normal user machine the user gets error when trying to filter.

I made sure it was also a 32bit excel version but I couldnt impound machine for too long course of busyness and wanted to hear if something about security could be the issue and if you heard about it before ?

Could i try other actions in add-in to narrow down problem ? I might have to do on other normal user machine since this user is very busy.

Nov 14, 2012 at 4:04 PM

Are you talking about the Filter List feature, or a different feature?

If you're an SSAS admin, then you might try editing the connection string inside your Excel and adding ;EffectiveUserName=DOMAIN\Username to the end of the connection string. Then you as an administrator will impersonate the permissions of the other user. Then try Filter List and see if you can reproduce the problem. If you have dimension security, that could explain the different behavior.

Nov 14, 2012 at 4:12 PM

Yes, the filter list feature.

I'll try this out but pretty sure they don't use dimensional security.

A guy here said it could be "an access to temporary files" problem - on local machine I'm administrator but add-in was installed on machine with someone who is allowed to install - would usage then be a problem ?

Nov 14, 2012 at 11:21 PM

I'm not aware of any issues like you describe. But please do capture the exact error messages and see if you can document steps to reproduce.

Nov 21, 2012 at 2:58 PM

Error when clicking search tab. Not typing anything just picking search tab.

Error when trying to clear pivottable cache

I now tried installation on one more random user machine with same result.



Nov 28, 2012 at 8:27 AM

Any suggestions on what could be the problem on other users machines / profiles ?

Nov 28, 2012 at 10:50 AM

Sorry for the delay in replying. As you can see from the Search tab error message, it's just blowing up on the Excel API's PivotCache.MakeConnection() function. This tells me that there is some reason the PivotTable can't connect.

Can you answer the following questions...

What version of my add-in are you using? Is the connection to an Analysis Services cube? What version? Is there anything different about the connection? Can you capture the connection string? Are you using the credentials of the user logged into the laptop, or are you specifying credentials for that connection? When you refresh your PivotTable, it succeeds? The PivotTable has some fields on rows, columns, or values?

Nov 28, 2012 at 2:25 PM

- the pivottable is connected and can be refreshed, and has fields on fows, columns values

- i tried connecting with add-on built by client themselves and also just by creating connection myself. Both gave error on normal user machines

- add in v0.8.0.0 (32-bit)

- connection to Analysis Services 2008 r2

- My connection. Beleive its the same on other machines but didnt compare: Provider=MSOLAP.4;Integrated Security=SSPI;Persist Security Info=True;Initial Catalog=(xx);Data Source=(xx);MDX Compatibility=1;Safety Options=2;MDX Missing Member Mode=Error (my machine works but I'm local administrator and olap admiistrator)

- I'm using the users own credentials when trying out on their machines

Dec 13, 2012 at 11:51 AM

Any ideas on where to look to find the cause ?

Dec 20, 2012 at 4:04 PM

You might consider renaming Microsoft.AnalysisServices.AdomdClient.dll in the OLAP PivotTable Extensions install directory (under Program Files or under Program Files (x86)). Then try installing ADOMD.NET from a SQL Server feature pack. That would be one of the files named "SQLSERVER2008_ASADOMD10" from:

If that helps, please keep me posted.

Otherwise, you might connect Profiler to Analysis Services and see what you see when your user connects.

Sorry for the delay in replying.